Resolved
The situation is resolved, our systems have caught up with synchronizing delayed data.
Investigating
We are facing issues with calls and call history. Call history is not showing recent calls. Calls will appear with some delay. We are working on fixing the problem and synchronizing delayed data.