All applications are fully functional
Resolved
Monitoring
Problem has been addressed, we are monitoring the situation
Investigating
We are facing performance issues with some of our applications. Our engineering team is investigating the root cause.