Missing analytics data for US customers
Identified·Degraded performance

Analytics are available from 15th of April 12:30 UTC for US customers.

We are working to restore the missing analytics data created between 13th of April 8:00pm UTC and 15th of April 12:30 UTC.

Tue, Apr 15, 2025, 01:03 PM
(1 week ago)
·
Affected components
Updates

Identified

Analytics are available from 15th of April 12:30 UTC for US customers.

We are working to restore the missing analytics data created between 13th of April 8:00pm UTC and 15th of April 12:30 UTC.

Tue, Apr 15, 2025, 01:03 PM

Investigating

We are investigating an issue with the missing analytics data for customers using US region from 13th of April 8:00pm UTC until 15th of April 12:30 UTC.

We know this is frustrating and we’re working to resolve this as soon as possible. We have escalated this to our engineering team, and will provide an update as soon as more information becomes available.

Tue, Apr 15, 2025, 12:48 PM(15 minutes earlier)
Powered by