Connection issues in Asia region
Monitoring·Degraded performance

The affected region is currently being rerouted through Europe.

We plan to restore the original routing as soon as we have completed a full review of all systems.
In the meantime, customers in Asia may experience longer dialing times.

We sincerely apologize for the inconvenience and appreciate your patience.

Fri, Jul 11, 2025, 02:31 PM
(16 hours ago)
·
Affected components
Updates

Monitoring

The affected region is currently being rerouted through Europe.

We plan to restore the original routing as soon as we have completed a full review of all systems.
In the meantime, customers in Asia may experience longer dialing times.

We sincerely apologize for the inconvenience and appreciate your patience.

Fri, Jul 11, 2025, 02:31 PM

Identified

We have re-routed Asia customers to backup region. Connections are possible again.

Fri, Jul 11, 2025, 01:29 PM(1 hour earlier)

Investigating

Our phone application is currently experiencing connection issues in Asia region. We know this is frustrating and we’re working to resolve this as soon as possible. We have escalated this to our engineering team, and will provide an update as soon as more information becomes available.

Fri, Jul 11, 2025, 01:27 PM
Powered by