Pipedrive Synchronization Issue for Selected Customers
Identified·Degraded performance

We have identified and resolved the root cause of the issue. Synchronization with Pipedrive has resumed. Please note that the backlog of data will take several hours to fully process, so customers may continue to experience temporary delays or see missing data until the queue is cleared.

Mon, Sep 1, 2025, 04:19 PM
(16 hours ago)
·
Affected components
Updates

Identified

We have identified and resolved the root cause of the issue. Synchronization with Pipedrive has resumed. Please note that the backlog of data will take several hours to fully process, so customers may continue to experience temporary delays or see missing data until the queue is cleared.

Mon, Sep 1, 2025, 04:19 PM

Investigating

We have identified an issue where CloudTalk is not synchronising properly with Pipedrive for a subset of customers. Our engineering team is actively investigating and working on a resolution. Updates will be shared here as progress is made.

Mon, Sep 1, 2025, 03:23 PM(55 minutes earlier)
Powered by