Resolved
All systems are functional
Monitoring
All routes to EMEA destinations have now been recovered. Our tests confirm that call delivery is functioning as expected. We continue to closely monitor the situation together with our carrier partners to ensure full stability.
Monitoring
We are currently experiencing issues affecting some voice calls to European destinations due to ongoing problems in our partner carrier network. Our team is actively working with the provider to mitigate the impact and reroute affected traffic where possible.
We will provide another update as soon as we have more information.
Monitoring
We have switched the incident to monitoring.
The affected carrier systems have recovered, and outbound call delivery is performing normally based on our latest tests.
We’ll continue to closely monitor performance to ensure the service remains stable before marking the incident as fully resolved.
Identified
We have applied traffic rerouting to alternative carriers, and call delivery is gradually improving.
According to our partners, the underlying computing engines outside of CloudTalk are now recovering.
Users may still experience occasional issues with certain destinations while the affected networks stabilize.
We continue to monitor the situation closely and will provide another update once full service is restored.
Investigating
We are currently experiencing an issue affecting outbound and inbound calls to certain European destinations and SMS.
The issue is caused by a major outage at one of our carrier partners. Our engineering and operations teams are actively working on rerouting the affected traffic through alternative carriers wherever possible.
During this time, users may experience intermittent issues when placing or receiving calls to/from specific numbers or destinations, as well as sending/receiving SMS outside of CloudTalk’s network.
Automatic number ordering for USA is also impacted at the moment
We will provide an update as soon as they are available