Voice services in US region have degraded performance
Resolved

This incident has been resolved.

Tue, Oct 10, 2023, 07:45 PM
(1 year ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, Oct 10, 2023, 07:45 PM

Investigating

We are currently investigating the issue

Tue, Oct 10, 2023, 06:57 PM(48 minutes earlier)
Powered by