Call history
Incident Report for CloudTalk
Resolved
This incident has been resolved.
Posted Aug 20, 2020 - 20:13 CEST
Update
We are continuing to investigate this issue.
Posted Aug 20, 2020 - 20:13 CEST
Update
Issue has been resolved.
Posted Aug 20, 2020 - 20:12 CEST
Investigating
We are currently resolving problem with missing call records in dashboard history. Affected region - US.
Posted Aug 20, 2020 - 18:33 CEST
This incident affected: CloudTalk's major components (CloudTalk Dashboard).