Desktop app - unable to install on Mac
Incident Report for CloudTalk
Resolved
This incident has been resolved. Please make sure your App version is 2.7.4. Re-install or an update of the application may be needed.
Posted Dec 20, 2021 - 17:59 CET
Investigating
The newest version of Desktop app is not possible to be opened on Mac. We're investigating the issue.
Posted Dec 20, 2021 - 10:18 CET
This incident affected: CloudTalk's major components (Desktop App).