Call history in Dashboard might not be visible for EU customers
Incident Report for CloudTalk
Resolved
The incident has been resolved
Posted Jan 25, 2024 - 13:26 CET
Monitoring
Data recovered
Posted Jan 25, 2024 - 12:24 CET
Update
Recordings data being restored. ETA 2-3 hours
Posted Jan 25, 2024 - 09:51 CET
Identified
Call history in Dashboard might not be visible for EU customers. Data will be restored.
Posted Jan 25, 2024 - 09:46 CET
This incident affected: CloudTalk's major components (CloudTalk Dashboard).