Issue on inbound and outbound calls
Incident Report for CloudTalk
Resolved
Both inbound & outbound calls are now working. Our team is still monitoring the results.
Posted Jun 22, 2020 - 11:32 CEST
This incident affected: CloudTalk's major components (Inbound Calls, Outbound Calls).