Voice services in US region have degraded performance
Incident Report for CloudTalk
Resolved
The incident has been resolved.
Posted Oct 11, 2023 - 18:06 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 11, 2023 - 17:38 CEST
Investigating
We are currently investigating the issue.
Posted Oct 11, 2023 - 17:37 CEST
This incident affected: CloudTalk's major components (Inbound Calls, Outbound Calls, Call Recording).