Higher dialing times in U.S. and Canada
Incident Report for CloudTalk
Resolved
Resolved
Posted May 15, 2024 - 16:29 CEST
Investigating
Customers in U.S.A. and Canada may be facing higher dialing times up to 30 seconds for outbound calls. It is caused by a 3rd party service provider and we are working on a solution.
Posted May 15, 2024 - 16:20 CEST
This incident affected: CloudTalk's major components (Outbound Calls).