CloudTalk degraded performance
Incident Report for CloudTalk
Resolved
Incident has been resolved. All CloudTalk's components are operational. We will publish public root cause analysis later today.
Posted Nov 22, 2023 - 11:24 CET
Update
Set of fixes have been successfully implemented. Team continues with the monitoring to confirm the suspected root cause.
Posted Nov 22, 2023 - 08:05 CET
Monitoring
All services are operational. Team prepared a series of fixes which will be implemented tomorrow (Wednesday) at 08:00 CET to cause the least impact and to confirm the suspected root cause.
Posted Nov 21, 2023 - 16:29 CET
Update
All services are operational again. Issue was caused by the new healthcheck configuration which was part of the incident remediation. We continue with the root cause investigation.
Posted Nov 21, 2023 - 15:23 CET
Identified
Multiple services have partial outage. We are working on a fix.
Posted Nov 21, 2023 - 15:19 CET
Update
Customers may experience issues with CloudTalk dashboard. Root cause of the incident hasn't been found yet. Infrastructure is monitored by engineers to minimize impact.
Posted Nov 21, 2023 - 15:10 CET
Update
Team continues with the investigation of the root cause.
Posted Nov 21, 2023 - 14:14 CET
Update
CloudTalk dashboard is operational again.
Posted Nov 21, 2023 - 13:35 CET
Update
Customers may experience issues with CloudTalk dashboard. Performance issues are connected with the ongoing incident. We are investigating root cause.
Posted Nov 21, 2023 - 13:28 CET
Update
Infrastructure has been scaled, new components will be added to running infrastructure in a few minutes. Team will closely monitor this action.
Posted Nov 21, 2023 - 13:05 CET
Monitoring
Team works on a scaling of affected infrastructure although applications are currently running and metrics don't show any issues. We are continuing with monitoring to ensure that possible peaks are covered as soon as possible.
Posted Nov 21, 2023 - 12:30 CET
Identified
Self-healing mechanism restored connections, services should be operational again. Team continues with investigation and further fixing.
Posted Nov 21, 2023 - 12:07 CET
Investigating
We are encountering degraded performance of our services. Team is investigating the root cause which might be connected with yesterday's outage.
Posted Nov 21, 2023 - 11:58 CET
This incident affected: CloudTalk's major components (Servers Availability, Inbound Calls, Outbound Calls, Call Recording, API, CloudTalk Dashboard, Desktop App, Mobile App, Integrations).