Issue with Inbound and Outbound calls in certain regions
Incident Report for CloudTalk
Resolved
This incident has been resolved and all calls are functioning as normal.
Posted Apr 08, 2022 - 15:45 CEST
Update
We are continuing to monitor for any further issues.
Posted Apr 08, 2022 - 13:54 CEST
Monitoring
A fix has been implemented for all affected companies and we are monitoring the results. Please contact our Support if problems persist.
Posted Apr 08, 2022 - 13:54 CEST
Investigating
We are currently investigating an issue with making both inbound & outbound calls. We will update this page with more information as we receive it.
Posted Apr 08, 2022 - 13:38 CEST
This incident affected: CloudTalk's major components (Inbound Calls, Outbound Calls).