Issue on inbound and outbound calls
Incident Report for CloudTalk
Resolved
Both inbound & outbound calls are now working. Our team is still monitoring the results.
Posted Jul 03, 2020 - 13:30 CEST