Call processing delay
Incident Report for CloudTalk
Resolved
This incident has been resolved.
Posted Jul 22, 2022 - 18:07 CEST
Investigating
Finished calls are processed with 10 minutes delay. This affects call visibility in dashboard.
We are currently investigating.
Posted Jul 22, 2022 - 16:28 CEST
This incident affected: CloudTalk's major components (CloudTalk Dashboard).