Call unavailability for certain regions
Resolved

This incident has been resolved.

Tue, Apr 21, 2020, 11:13 AM
(5 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, Apr 21, 2020, 11:13 AM

Identified

We've identified an issue with calls not being connected with some of our customers and are applying a fix.

Tue, Apr 21, 2020, 11:10 AM
Powered by