Call history not available for 0:20-1:20 CEST May 3rd
Incident Report for CloudTalk
Resolved
This incident has been resolved.
Posted May 03, 2024 - 22:07 CEST
Identified
For some customers call history might not be available in Dashboard for a time period of 0:20-1:20 CEST May 3rd.

Root cause is identified, we are working on a solution.
Posted May 03, 2024 - 13:42 CEST
This incident affected: CloudTalk's major components (CloudTalk Dashboard).