Outbound calls through one of our carriers are unavailable
Incident Report for CloudTalk
Resolved
This incident has been resolved.
Posted Oct 18, 2022 - 12:43 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2022 - 11:39 CEST
This incident affected: CloudTalk's major components (Outbound Calls).