Service delay
Incident Report for CloudTalk
Resolved
This incident has been resolved.
Posted May 05, 2021 - 23:02 CEST
Investigating
We are currently investigating this issue.
Posted May 05, 2021 - 21:32 CEST
This incident affected: CloudTalk's major components (CloudTalk Dashboard, Database Availability).